Connection is unstable or impossible when connecting through VPN
Problem
When connecting to the gotomyerp-hosted applications from within your company's network, the connection is successful and stable.
When connecting from a remote location, home, or from a company's network, and a VPN is connected, the user experiences different possible symtpoms:
- RemoteApp Disconnected
- The connection may get interrupted mid-session with a "Reconnecting" message.
- Other odd connectivity problems that may occur only when connecting through the VPN
Cause
These issues occur because of a misconfiguration in the VPN which ends up preventing successful or stable connections to the hosted environment.
Solution
Due to the wide variety of network configurations and VPN solutions, we cannot provide a specific solution. However, in most cases, the issue is due to a block or routing issue in the VPN configuration.
Unless you are the network administrator, your IT will need to be involved so that they can make the necessary modifications to your organization's VPN configuration.
General recommendations
- Configure VPN in a ways that traffic to gotomyerp servers is not routed through VPN. (VPN Split Tunneling).
We recognize that some organizations may have reservations to implement split tunneling due to security concerns and VPN configuration best practices. If that is the case, a VPN can still be configured for successful connection, but may require more knowledgable network admins to properly implement the necessary whitelisting. Please be advised that gotomyerp cannot assist in these configuration, and this task is the sole responsibility of the customer.
- Whitelist gotomyerp's IPs and ports. Since you have a private server with gotomyerp, please contact support@gotomyerp.com and request your servers IPs and Ports that need to be whitelisted.
- Make sure that the whitelisting of his traffic also includes signature based solutions, like Intrusion Detection Systems (IDS), Intrusion Prevention Systems (IPS), Perimeter Anti-Virus/Anti-Malware solutions that may be deployed.
Due to the wide variety of network configurations, gotomyerp can only provide general guidance on what needs to be done to facilitate this access. Your IT or network administrator will ultimately be responsible to make the necessary changes to allow a successful connection to the gotomyerp environment.
Related Articles
How to test connectivity for FileBridge using Telnet
Description Test FileBridge connectivity Why do this test? In order to connect to FileBridge drive, your Firewall and antivirus program shall allow communication to the FileBridge URL. When do you need to run this test? When one of the below is true: ...
Why do I keep getting disconnected from my session?
Problem: At random times, the session seems to get disconnected. When you log back in, in most cases, the application is where you left off. Reason: There are a few reasons why you may get disconnected from your application. Having the same user ...
gotomyerp RemoteApp - How do network bandwidth and quality of experience work together?
When you are looking at the overall network bandwidth required for gotomyerp RemoteApp, keep in mind the following factors - these are all part of a dynamic system that impacts the overall user experience. Available network bandwidth and current ...
Receiving message: Your computer was unable to connect to the remote computer
Problem: When attempting to launch an application from the portal, the following message almost immediately pops up, preventing the connection from succeeding: Reason: A bug has been introduced to a release Microsoft update, which causes a certain ...
gotomyerp RemoteApp network bandwidth - general guidelines (if you can't test your own)
If you do not have the time or capability to run the network bandwidth tests for gotomyerp RemoteApp, here are some fairly generic guidelines that can help you estimate network bandwidth per user. If you have a mix of these scenarios, we don't ...