Printing to a redirected PDF printer fails or crashes remote app

Printing to a redirected PDF printer fails or crashes remote app

Problem:

When attempting to save a PDF directly to the local workstation, it either fails or crashes the hosted application.

Cause:

Printing a PDF directly to the local system is only possible out of the box if the user is printing to the "Redirected" PDF printer. (For example, printing to the printer named: Adobe PDF (Redirected #11) )
While this method works most of the time, local environmental factors could cause it to fail or crash.

Solution:

There are a few solutions to save a PDF to the local workstation.

  1. Print your document to the local PDF printer on the server. (The one that does not have the word: (Redirected ##) after its name), then save that file on your G: drive, Desktop, or Documents on the server, then pick up that file from your FileBridge. (See Interactive Guide on using FileBridge)
  2. Use TSPrint, an advanced RemoteApp printing solution with many additional features and capabilities, one of which is to save to a local PDF. Your plan may already include this solution, and you only need to activate it. Please get in touch with sales for more information.
  3. Attempt to use a different redirected PDF printer. For example, if the "Adobe PDF (Redirected ##)" is not working correctly, try to use "Microsoft Windows XPS Printer (Redirected ##)" instead.
Note that while Adobe PDF (Redirected ##) may have worked at one point, it is not guaranteed to always work in the same way due to local environmental factors such as local driver updates, Windows updates, or other variables.
For this reason, gotomyerp does not support printing directly to a Redirected PDF printer. Support for such a scenario is provided on a best-effort basis only.



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